Sportbike World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I am trying to install flush mounts to my 900 and am having a problem with the lights flashing way to fast, as if a bulb is bad. The bike has 3 wires and the new lights only have 2. I don't mind not having the running lights. But I can't make the new lights stop flashing so fast. Can someone please help me? Do I need to get a different light bulb?

------------------
 

·
Registered
Joined
·
1,429 Posts
Had the same problem- the wire colors/stripes do not match between the stock and aftermarket signals. Instead, go by the descriptions of the wires included with the new signals (ground,hot). BTW, Lockhart does offer 2 or 3 wire models. Plan to replace the bulbs frustratingly often, they are cheap-ass sheeeeeiittt!

------------------
'98 Superhawk
 

·
Registered
Joined
·
12 Posts
The 3 wire is a dual filament. Yes LF makes them, I bought a set for the rear of my bike. Mine was backwards, 3 wire light, 2 wire stock. Easy solution here, just tie the two hots together. On my car however i had your problem, to avoid the faulty circuit flash, i had to use a relay to actually disconect the constant power with the pulsating one. standard bosch relay can be bought at auto supply, or stereo shop. Otherwise, the rapid flash gets more attention...you know, to the lady in the 10,000 lb excursion, eating a burger, and yelling at her 18 kids in the back seats. :)
Well hope this helps

------------------
15,500 Rpm Redline...
If its not an indy car,
it must be a YZF-R6. =)
 
1 - 3 of 3 Posts
Top