Sportbike World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1 (Edited)
Picked up a used ninja 500, 1990 with a 94 engine in it. It was left in storage for a long time witout fuel stabalizer for a long time. It wouldn't stay on without the choke... my guess was stale gas and a dirty carb. So i emptied the tank and took out the carbs and cleaned them out. Now it runs much better however it still gives me a little trouble that puts me in dangerous situations. It adds throttle on it's own sometimes without input and pulls along, a jerky ride. When i'm going into turns and it happens to do that it throws off my steering a bit... can anybody gives me any suggestions as to what i might have to tweak? Thanks in advance....
 

·
Registered
Joined
·
155 Posts
Sounds like a possible vacuum leak. Check all the vacuum hoses, and replace if they look cracked, or just old. Also check the boots connecting the carbs to the intake. Sometimes they go bad, or might not be seated all the way on causing a intermittent leak.

I'm sure the carb gurus will be along to throw some better suggestions out, but that sould get you started.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
Thanks for the tip, i thought that might be it too, however I'm not sure what hoses to check. I just got the repair manual and am going to take a look. I'm also going to replace the spark plugs and wires. If all that doesn't work then i'm going to assume it may be a head gasket leak. Thanks again.
 

·
Registered
Joined
·
25 Posts
you could have a tight throttle cable. When you push on the handlebars to corner, there isn't enough slack in the cable and the throttle gets rolled a little bit.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #5
well seems i've found just a little bit of a problem in that only one spark plug was actually firing haha.... seems the guy i bought this bike from had no idea of all this stuff, can't be a good sign of things to come. I replaced the spark wires and plugs and it's a night and day difference. However can't celebrate yet, because it still is a little jerky, and i've noticed oil leaking out of the engine block, it's not a whole lot of oil so i don't know if i should be concerned.
 

·
Registered
Joined
·
8,798 Posts
Where is it leaking from? does it have water in it?

If I had to guess its probly leaking from the valve covers.. those are troublesome on '90s kawis... But if the ammount isnt great, I wouldnt sweat it
 

·
Registered
Joined
·
135 Posts
Discussion Starter #7
Thanks for all the help you guys have been giving me i appretiate it. However my bike is still being a whooore, just doesn't seem to wanna run right. I'm thinking of opening up the engine block and taking a look at the head gasket. Can i do this without taking the engine out of the bike's frame? It just doesn't sound right when it's idleing there's too much pinging and rattling, and it's not producing anywhere close to the power it's supposed to. Also the fork springs seem really mushy. Does anybody know what i'm going to need to replace on the forks, is it just the springs or the whole tube?... yeah as you can tell i have little idea where to begin and i'd appretiate all the help i can get, thanks again for all the help.
 
1 - 7 of 7 Posts
Top