Sportbike World banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hi

i just bought a '99 ZX7R and i love it

but now it has a problem
- every time i give the bike throttle it blows my fuse for my headlights

so i was thinking of checking the following:
- voltage regulator
- make sure the correct bulbs are in the bike

does anyone else have any suggestions or might know what exactly is causing this?
 

·
Registered
Joined
·
8,798 Posts
Sounds like the regulator is shot. Get it changed quick before it fried the ignition.
 

·
Registered
Joined
·
1,170 Posts
V. is most likely right, but before you spend your money take a few minutes to pull the tank & check your wiring for spots where the insulation has burned or rubbed through, or burning at the connectors.
 

·
Registered
Joined
·
8,798 Posts
bmacd said:
bike's don't have alternators...they have regulators and rectifiers.

-=bmacd=-
Are ya sure about that? I thought they had an alternator and a rectifier? (Alternator generates AC, rectifier converts it to DC and filters)
 

·
Registered
Joined
·
21 Posts
i had the same exact problem. i have a 2000 zx9r. i finally decided to follow the harness and see if there were any spots rubbed to the wire. well low and behold the harness was ran under the airbox. over time, it rubbed the harness down to the bone, so to speak. the wire it rubbed bare just so happened to be the headlight power wire. a couple snips, some good bell caps crimped down real well, rerouted the harness over the air box, and good as new. better than new. check the harness before ou go spending money. good luck!!
 
1 - 12 of 12 Posts
Top