Sportbike World banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all I am new to the community and recently been having issues with my 2001 gsxr 600.

I'm a new rider this is my first bike and I've had it for about 3 months with no issues. I just bought a new battery and charged it fully and put it in. After a few rides I was on my way home one night and the speedometer HUD went blank while i was going 120km/h on the high way.. then about 1 minute later it started to bog out on me and had no power at all and forced me to pull over. The bike went completely dead when I stopped. So I left it there and took the battery home and got a ride to charge it. I assumed i didnt charge it enough when I bought It. So I recharged it for 6 hours and got my bike and everything was fine until today when it did the exact same thing. Does anyone know what might be causing this? I'm thinking stator. But why would it randomly stop working when it was fine before?

Anything helps thanks alot guys!!!
 

·
Registered
Joined
·
3 Posts
Hello all I am new to the community and recently been having issues with my 2001 gsxr 600.

I'm a new rider this is my first bike and I've had it for about 3 months with no issues. I just bought a new battery and charged it fully and put it in. After a few rides I was on my way home one night and the speedometer HUD went blank while i was going 120km/h on the high way.. then about 1 minute later it started to bog out on me and had no power at all and forced me to pull over. The bike went completely dead when I stopped. So I left it there and took the battery home and got a ride to charge it. I assumed i didnt charge it enough when I bought It. So I recharged it for 6 hours and got my bike and everything was fine until today when it did the exact same thing. Does anyone know what might be causing this? I'm thinking stator. But why would it randomly stop working when it was fine before?

Anything helps thanks alot guys!!!
Replace your stator & regulator at the same time. People will say don't buy from Amazon but I replaced mine over a year ago and still working fine. I also suggest getting a battery tender. A common problem with gixxers of the early 2000's.

Sent from my moto g(7) power using Tapatalk
 
1 - 2 of 2 Posts
Top