Sportbike World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
OK guys, the Z50R is still giving me trouble. I've sprayed carb cleaner in about every hole on the thing. I took the carb off and sprayed it out and tried spraying cleaner through the fuel inlet and all that, too. Put it back on and it does the same as before:

If I spray a burst of starter fluid into the carb through the air intake (airbox is off), it will start, rev up really high, and then die off once all the fluid has burned off. It did the same when I took the carb off, I sprayed fluid in the metal 90 degree joint-piece that attaches the carb to the engine, and it did the same start, rev high, and die routine.

However, I can't get it to burn fuel. The bike sat for a long time, so I drained the fuel, put new gas in there with a little bit of STP gas cleaner, and tried it again. Still nothing. I thought maybe the gas inlet was clogged...but gas came out the drain hose when I loosened a screw at the bottom. It looks like the idle screw, but it's a few inches down and obviously is not the idle screw. When I loosened that, fuel would come out the carb's drain hose, and when I tightened it all the way, the fuel would stop again. Also, I seemed to be able to hear fuel flowing in when I first opened the valve again after putting the carb back on.

It won't crank with the choke open or closed. My throttle sticks a bit, but it won't crank whether I leave it closed, or have it open.

I couldn't see anything when I had the carb off. It seemed really simple and I couldn't see any problems.

What do you think? What's wrong with it? It ran fine prior to sitting for a year or two.

THANKS!
 

·
Registered
Joined
·
580 Posts
Well either fuels not getting to the carb, or the carbs not working. Im not familiar with your bike but that sounds logical to me. Look at the carb again, seems like you've missed something. Try it also with the fuel cap off in case a vent is clogged.
 

·
Registered
Joined
·
4,230 Posts
The carb needs to be taken apart and internal passages cleaned, not just squirting off the visible stuff.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
yeah, I squirted out any little passage-ways I could find when I took it apart the first time.

took it apart a second time tonight, and the bottom part was filled with gas. So I'm thinking it's definately getting gas. The reason it was so flooded was something was wrong with the little pilot screw for the throttle and it would only go in the reverse (180 degrees) way...I adjusted that a little and got it in the right way, and now the throttle piece sits like it should.

Put the carb back on, the throttle doesn't stick now that it's in there right ;-), but it still will only run on the spray.

If I rev the throttle while burning the fluid, it still revs up, but it still dies off at the end.

Could it be the plug? I cleaned it w/ sandpaper and carb cleaner to get some carbon buildup off, but it could just be old...would it be possible that it's good enough to ignite starter fluid, but not strong enough to ignite the gasoline?

Thanks again guys
 

·
Registered
Joined
·
580 Posts
I doesnt sound like its the plug, but a new one is only a few dollars... why not put your mind at ease and get a new one? When you put the carb back on you arent putting the air filter on too are you? Have you tried just squirting a little gasoline into the intake and starting it? That would narrow it down to the carb like we said if it will run that way. And don't try cranking it holding the gas container at the intake, a guy in our auto shop class in high school set himself on fire when the gas filled GLASS GATORADE JUG :rolleyes: he was holding over the carb of an old Mach 1 exploded when the carb backfired. Guess Im dating myself a bit, how long has it been since Gatorade came in a glass jug? Anyway, I digress. Good luck.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
How would I spray just a little gas in there? I mean, not to seem stupid, but it just seems weird putting a little gas in a squirt bottle or something, but the 5 gal. can is definately too big. And if it won't burn fuel that way, it's the carb that is the problem?

Nah, I'm leaving the filter off. I tried putting it on like once in case the free-er flowing air was causing it to not crank for some reason, but it's been off 99% of the time.

I'll go ahead and get the plug, at least I will have that ruled out as well if it doesn't cure it. If that doesn't help, and it won't burn the gas squirted in the carb, it's a problem with the carb, huh? since it will burn the starter fluid even w/ no carb...
 

·
Registered
Joined
·
580 Posts
murfnamedsmurf said:
If that doesn't help, and it won't burn the gas squirted in the carb, it's a problem with the carb, huh? since it will burn the starter fluid even w/ no carb... [/B]
If you read my post carefully you will see that I said if it WILL run on the gas squirted in then its a problem with the carb. If it will burn gas you put in by hand, the carb is not passing the right amount of fuel to the engine on its own. All you need to do is splash a little bit of gas in and try cranking it.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
Either way it's probably a problem with the carb, eh? Cause if it does work, you say it is a problem with the carb. But if it doesn't work that way, don't you figure it's still a problem with the carb?

How much $$ do the carbs run on a little 50cc engine?
 
1 - 8 of 8 Posts
Top