Sportbike World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I need to take my baby to a shop and see what's going on with it! I believe one of the pistons is greating enough compression. The good thing is that it's not smoking or anything but it can barely run! It tends to shut off once i let off the throttle and chokes once i try to turn it back on.

I need to start rding soon.......:(
 

·
Registered
Joined
·
34 Posts
BELTS?

No problems with the belts on the last three Ducatis I have owned. All had the belts changed at the regular service periods and they never looked bad. What kind of miles do you have on your 748? Are you sure it is the belts? Let us know...:confused:
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Well i'm not sure if it is the belts or not!:( I do know that one piston is not working properly, i have yet to do a compression check cuz i can't find a compression tester that will work on bikes.

Who knows maybe the pistons or rings might be damaged? But what makes me wonder is that there is no smoke or oil coming out the exhaust.

The problem happen a few weeks back when i was topping out the bike and the motor felt like it the rev limiter but it didn't hit it! Next thing i know the bike is slowing down dramatically and shuts off! I finally got it started but it seems to get flooded and smells like gas bad!

I guess i might have to open it up :mad:
 

·
Registered
Joined
·
455 Posts
Sounds like you seized it to me.

FWIW there was a complete new 748 motor on ebay for 2500 last week. If I were you I'd check it out.
 

·
Registered
Joined
·
1,452 Posts
just a few ideas

sounds more like a fuel problem.

Check fuel pump pressure!
Check leaks in fuel pressure line to injectors ( would expalin the smell)
check tank internal pump hose pressure loss = running badly
Fuel tank quick fit connectors.


So far in three years I've had all of the above go on me.

Cheers
 
1 - 5 of 5 Posts
Top