electrical issue - Sportbike Forum: Sportbike Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-17-2010, 01:55 PM Thread Starter
Registered User
 
Join Date: May 2010
Location: Tampa FL
Posts: 1
Unhappy electrical issue

I'm having an electrical issue,

My 06 gsxr 600 starts and the headlight works, but any other electronic is not working ie: brake light/turn signals/tachometer/speedometer. Ive replaced the fuses. which i see everything light up for a second, then hear a slight pop and it shuts off. Any advice of why is appreciated
buckeye_2005 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-18-2010, 11:02 AM
Strength and Honor
 
kanwisch's Avatar
 
Join Date: Oct 2002
Location: Central IN
Posts: 6,144
There is a short in your electrical system somewhere. You have to find it and repair it. Generally this is caused by having done something recently, like putting on some new electronic device (neons, for instance) or from having drilled through or pinched through an electrical line's insulation. There are other possibilities but I don't know enough about a gixxer's electrical layout to offer more insightful advice.

SportbikeWorld Supermoderator

Dragging knee is for the track, and dragging tail is for the lot. --Kane Friesen

When you're in a car, you're watching a movie; when you're on a bike, you're in the movie. --Robert Pirsig

Identity theft is not Fun
kanwisch is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbike Forum: Sportbike Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome