Fuel Injector Cleaner Problem - Sportbike Forum: Sportbike Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-30-2013, 10:56 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Location: Hayward, CA USA 94545
Posts: 2
Fuel Injector Cleaner Problem

Several months ago I put half a bottle of fuel injector cleaner in my 954 and it caused the bike to run rich and it fouled the plugs. I bailed the gas with FI cleaner in it and put new gas. I put new spark plugs in asap which set me back $60. (I realize now that I could have cleaned the plugs) About 100-200 miles later, I tried to start the bike and it wouldn't fire up. I've talked to a few dealerships and they said it might be a sensor or something is clogged. Any ideas? What could the FI cleaner have done to the bike and if all of it is out of the bike, what should be checked?
chrsiat954 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-30-2013, 12:23 PM
Registered User
 
Join Date: Apr 2013
Location: Raleigh, NC USA 27603
Posts: 4
Shouldn't you be running 93 in a 954 anyway? If you're using decent gas, it should have additives that would make FIC totally unnecessary.
vansjeansvnecks is offline  
post #3 of 4 (permalink) Old 04-30-2013, 06:58 PM Thread Starter
Registered User
 
Join Date: Apr 2013
Location: Hayward, CA USA 94545
Posts: 2
Would that by itself be the problem? The manual says I should be using 91 but I've been using 87(??) whatever is the lowest in CA. If that's the only problem then all I gotta do is flush that old gas out.
chrsiat954 is offline  
 
post #4 of 4 (permalink) Old 05-01-2013, 09:01 AM
Registered User
 
Join Date: Apr 2013
Location: Raleigh, NC USA 27603
Posts: 4
Using a lower octane than the manual calls for is bad news. You can potentially do engine damage. If it hasn't been knocking, though, it's probably another issue. Top it off with 91 and try it again.
vansjeansvnecks is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbike Forum: Sportbike Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome