How to mount flush mount signals on 99 F4?? Please help. - Sportbike Forum: Sportbike Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-17-2000, 05:24 PM Thread Starter
Registered User
 
Join Date: Jul 2000
Location: Tucson Az
Posts: 70
Question

I have a 99 F4 and am wondering how to mount the flush mount front turn signals. If anyone can help I would appreciate it.

Nate

------------------
F4Missile is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-18-2000, 12:37 PM
Registered User
 
FZR400Tony's Avatar
 
Join Date: Sep 1999
Location: Pittston, PA 18640
Posts: 3,644
Send a message via Yahoo to FZR400Tony
Post

nate are you having a problem with the bends of the bodywork (i.e. getting them flush) or just mounting in general.

sorry, can't help with f4 specific stuff.

also front or rear?

------------------
Tony

the views and opinions expressed by tony (cbrf2boy) are the ramblings of a total idiot. sbw.com, it's administrators, moderators, and members don't necessarily agree with and are not responsible for anything this idiot has to say.
FZR400Tony is offline  
post #3 of 6 (permalink) Old 07-18-2000, 12:49 PM
Registered User
 
Join Date: Jul 2000
Location: Stoughton, MA, USA
Posts: 4
Post

I too need help installing flush mount signals on 929...not sure about wiring??
louieville sluggah is offline  
 
post #4 of 6 (permalink) Old 07-24-2000, 04:21 PM
Registered User
 
Join Date: May 2000
Location: Tucson, AZ 85711
Posts: 12
Post

Nate, as soon as my clears come in, I can help you do yours at the same time. Just come by my work probably thursday, and we can make arangement for fri. As for slugga, I will be moding the fender, and doing the turn signals, on my friends 929, probably next week, I'll let ya know the specifics on that.
Laterz

------------------
15,500 Rpm Redline...
If its not an indy car,
it must be a YZF-R6. =)
2kRacer6 is offline  
post #5 of 6 (permalink) Old 08-02-2000, 01:20 PM
Registered User
 
Da Rookie's Avatar
 
Join Date: Apr 2000
Location: San Jose, CA, USA 95148
Posts: 35
Post

i bought some lockhard phillips flush mount signals for my F4...and they dont fit. it's impossible to get them flush on the fairing. im trying to find another manufacturer who makes some that fit.

------------------
Da Rookie is offline  
post #6 of 6 (permalink) Old 08-09-2000, 03:23 AM
Registered User
 
Join Date: Apr 2000
Location: Pembroke Pines, FL
Posts: 43
Send a message via AIM to Tungue
If you find another brand that fits, let me know. I'm also looking around for a set that'll fit.

------------------
Tungue is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbike Forum: Sportbike Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome